Wprowadzenie

 Początek Następny

Wprowadzenie

Kancelaria Prawna.WEB umożliwia dostęp i edycję danych programu Kancelaria Prawna z poziomu przeglądarki internetowej. Zarówno funkcjonalność jak i sama obsługa Kancelarii Prawnej.WEB nie odbiega znacząco od wersji desktop Kancelarii Prawnej.


Wymagania systemowe

 Początek Poprzedni Następny

Wymagania systemowe

Serwer WWW - komputer, na którym instalowana jest Kancelaria Prawna Gold .Web (IIS serwer):

· Wymagana wcześniejsza instalacja serwera WWW Microsoft IIS wersja 6 lub wyższa
· Wolne miejsce na dysku twardym minimum: 500 MB

Wymagania minimalne:

· Windows Vista Bussines/Vista Enterprise/Vista Ultimate/7/8/8.1 (zalecana mała liczba użytkowników - do ok. 10 podłączonych jednocześnie)
· Pamięć operacyjna 2 GB
· Stałe połączenie z internetem (ze stałym adresem IP) umożliwiające łączenie się z zewnątrz z programem; przepustowość łącza minimum: 512 kb/s (upload)

Wymagania optymalne:

· Windows 2003/2008/2011/2012 Server (nieograniczona liczba jednocześnie podłączonych użytkowników)
· Pamięć operacyjna od 2 do 4 GB w zależności od ilości jednocześnie obsługiwanych użytkowników i wielkości bazy danych
· Stałe połączenie z internetem (ze stałym adresem IP) umożliwiające łączenie się z zewnątrz z programem; przepustowość łącza minimum: 1024 kb/s (upload)

Uwaga!

Do poprawnego działania Kancelarii Prawnej Gold WEB po stronie serwera niezbędny jest Framework .NET 4.0. Podczas instalacji KP.WEB jest on pobierany z witryny internetowej (ok. 50MB), w przypadku braku dostępu do internetu instalacja .NET 4.0 musi być przeprowadzona ręcznie przed instalacją KP Gold WEB.

Na każdym stanowisku z którego uruchamiany będzie KP Gold WEB konieczna jest instalacji w przeglądarce wtyczki Flash Player ActiveX.

Konfiguracja IIS

Przed przystąpieniem do instalacji KP.WEB konieczne jest zainstalowanie i skonfigurowanie serwera IIS. Konfiguracja IIS różni się w zależności od systemu operacyjnego. Poniżej przedstawiono w formie zrzutów z ekranu, opcje które powinny być włączone podczas instalacji IIS.

Windows XP Professional

Dodajemy składnik systemu Windows Internetowe Usługi Informacyjne, w trakcie instalacji potrzebny będzie nośnik instalacyjny MS Windows.

Windows Vista

Podczas instalacji IIS należy zaznaczyć opcję jak pokazano poniżej

Windows Server 2003

Windows Server 2008

Windows Server 2008 R2

W wersji IIS 7.5 dokonujemy podobnego wyboru komponentów do zainstalowania.

Windows Server 2012

Windows 8.1


Instalacja KP.WEB

Instalacja KP.WEB

Instalacji KP.WEB dokonujemy na tym samym serwerze na którym działa usługa IIS oraz zainstalowana jest Kancelaria Prawna.

Uwaga!

Przed instalacją KP.WEB, na serwerze musi być zainstalowana Kancelaria Prawna i co najmniej raz uruchomiona z konta administratora (SYSDBA).

W trakcie instalacji KP.WEB sprawdzana jest obecność pozostałych wymaganych składników, tj. oprogramowanie Kancelaria Prawna, serwer IIS, a w przypadku braku jednego z nich wyświetlany jest stosowny komunikat. W trakcie instalacji może być również pobierany i następnie instalowany Microsoft .NET 4.0.

W kolejnych krokach instalacji KP.WEB musimy określić lokalizację dla dokumentów. Możemy wprowadzić kilka takich lokalizacji, należy pamiętać o tym by serwer IIS miał prawo odczytu i zapisu do tych folderów. Dokładniej chodzi o użytkownika IIS_WPG oraz ASPNET.

W kolejnym kroku generujemy certyfikat zabezpieczeń.

Aby certyfikat działał poprawnie przy połączeniu szyfrowanym, musi być on odpowiednio wygenerowany, w zależności od tego czy dostęp do KP.WEB ma być z sieci lokalnej (lub VPN), czy przez internet. Domyślnie jest on generowany dla nazwy komputera na którym instalujemy KP.WEB. Jeśli KP.WEB ma być dostępny przez internet, wówczas konieczne jest wygenerowanie certyfikatu z właściwą nazwą domeny.

Jeśli KP.WEB jest już zainstalowany, w celu ponownego wygenerowania certyfikatu konieczna jest deinstalacja i ponowne zainstalowanie KP.WEB.

Uwaga!

Dotyczy systemów Windows XP: w celu umożliwienia lokalnego uruchomienia KP.WEB (na serwerze poprzez wpisanie adresu localhost/kpweb) konieczny jest restart komputera po instalacji KP.WEB.

Konfiguracja KP.WEB

W pliku web.config (w folderze aplikacji - domyślnie C:\KancelariaPrawnaWEB\) w sekcji "USTAWIENIA PROGRAMU" można zmienić ustawienia takie jak: ścieżki folderów dokumentów oraz adres i ścieżkę do pliku z bazą danych. Wszystkie pola, które można edytować są w pliku odpowiednio opisane. Zmiana pól spoza tej sekcji nie jest zalecana.


Konfiguracja dostêpu do dokumentów

Konfiguracja dostępu do dokumentów

Konfiguracja dostępu do dokumentów

Poniższe informacje dotyczą wersji KP Gold i Silver.

W celu umożliwienia dostępu do dokumentów zarówno z KP.WEB jak i końcówek sieciowych Kancelarii Prawnej, trzeba dokonać odpowiedniej konfiguracji IIS oraz wprowadzić ręczne modyfikacje w pliku web.config umieszczonego w katalogu \KancelariaPrawnaWeb.

Zmiana użytkownika IIS

Dostęp do sieciowych zasobów z KP.WEB jest możliwy tylko wówczas, gdy IIS będzie działał na koncie lokalnego użytkownika. W tym celu tworzymy lokalne konto dla zwykłego użytkownika (w przypadku domeny musi to być użytkownik domenowy). Następnie korzystając z Panel sterowania - Narzędzia administracyjne - Internetowe usługi informacyjne, we właściwościach wirtualnego foldera KPWeb, na zakładce Zabezpieczenia folderów wybieramy Edytuj (Dostęp anonimowy i kontrola uwierzytelnienia) podajemy tego użytkownika zamiast domyślnego.

Po tych zmianach restartujemy serwis IIS.

Ważne jest by dodany użytkownik miał pełne prawa do katalogów z udostępnionymi dokumentami oraz do katalogów KancelariaPrawna\Temp i C:\Documents and Settings\[nazwa_komputera]\ASPNET\Ustawienia lokalne\Temp.

Konfiguracja web.config

Kolejną rzeczą jest wprowadzenie ręcznych zmian do pliku \KancelariaPrawnaWeb\Web.config.

W kluczu mappedDiskDictionary wpisujemy literę dysku pod jaką mapowany jest zasób z dokumentami na końcówkach sieciowych z zainstalowaną Kancelarią Prawną jak również podajemy ścieżkę UNC tego zasobu. Ważne! Dysk musi być podany wielką literą.

Następnie w kluczu fileRoots podajemy nazwę (alias) zasobu, który będzie wybierany podczas dodawania dokumentów w KP.WEB, również podając scieżkę UNC jak powyżej.

Przykład:

<add key="mappedDiskDictionary" value="K:\=\\10.22.2.32\docs\"/>

<add key="fileRoots" value="dokumenty=\\10.22.2.32\docs\"/>

Na końcówkach gdzie zainstalowana jest Kancelaria Prawna zasób w tym przykładzie \\10.22.2.32\docs\ musi być zmapowany jako K:.


Instalacja na stacjach roboczych

Instalacja na stacjach roboczych

Podczas instalacji na stanowiskach roboczych określić należy adres komputera na którym zainstalowany został IIS i KP.WEB.

Po instalacji na stanowisku komputerowym w menu Start tworzony jest skrót do Kancelarii Prawnej.WEB.


Rozwi¹zywanie problemów

Rozwiązywanie problemów

 Początek Poprzedni

Nie pojawia się okno logowania (Windows XP Prof.)

Po wpisaniu adresu w przeglądarce nie pojawia się okno logowania do KP.WEB, cały czas wyświetlany jest kursor w postaci zegarka, nie jest zgłaszany żaden błąd.

Należy przenieść użytkownika IUSR_NazwaKomputera (Konto Internet Guest) z grupy Goście do Użytkownicy.

Nie można dodawać dokumentów z przeglądarki Firefox przy połączeniu przez protokół https

Problem ma związek z zabezpieczeniami w Firefox. Rozwiązaniem jest zainstalowanie certyfikatu KP.WEB w przeglądarce Internet Explorer. Należy postąpić wg poniższych ekranów.

1. wpisać adres KP.WEB w przeglądarce IE

2.Wybrać opcję "Kontynuuj przeglądanie tej witryny"

3. W pasku adresu kliknąć na napis "Błąd certyfikatu"

4. Wybrać opcję "Wyświetl certyfikaty"

5. Kliknąć w przycisk "Zainstaluj certyfikat"

6. Wybrać opcję "Umieść wszystkie certyfikaty w następującym magazynie" i wybrać następnie magazyn "Zaufane główne urzędy certyfikacji"

7. Potwierdzić zakończenie procesu instalowania certyfikatu.

1. wpisać adres https KP.WEB w przeglądarce IE

2.Wybrać opcję "Kontynuuj przeglądanie tej witryny"

3. W pasku adresu kliknąć na napis "Błąd certyfikatu"

4. Wybrać opcję "Wyświetl certyfikaty"

5. Kliknąć w przycisk "Zainstaluj certyfikat"

6. Wybrać opcję "Umieść wszystkie certyfikaty w następującym magazynie" i wybrać następnie magazyn "Zaufane główne urzędy certyfikacji"